ComponentSpace

Forums



Issue with ADFS when using mobile devices


Issue with ADFS when using mobile devices

Author
Message
neil.redfern@bis-web.com
neil.redfern@bis-web.com
New Member
New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)

Group: Forum Members
Posts: 3, Visits: 4
Hello,

We currently have an issue where our clients are unable to authentication using ADFS on mobile devices, but not via desktop machines using the same configuration.

I believe the error in the ADFS logs relate to an invalid certificate been used, I'm trying to get the exact message so I can included it but I'm depend on the client.

Do you have any idea what could be causing this?  Or what additional information would you require.

Thanks

Neil
ComponentSpace
ComponentSpace
ComponentSpace Development
ComponentSpace Development (2.9K reputation)ComponentSpace Development (2.9K reputation)ComponentSpace Development (2.9K reputation)ComponentSpace Development (2.9K reputation)ComponentSpace Development (2.9K reputation)ComponentSpace Development (2.9K reputation)ComponentSpace Development (2.9K reputation)ComponentSpace Development (2.9K reputation)ComponentSpace Development (2.9K reputation)

Group: Administrators
Posts: 2K, Visits: 4.6K
Hi Neil,
I'm not sure why this would be specific to mobile devices.
In both instances (mobile and desktop) do users start at the same SP website and then SSO to ADFS?
If so, I would expect they would use the same SAML configuration.
Are users prompted to login at ADFS in both instances?
To investigate further we would need the associated error events in the Windows ever log on the ADFS server.
We would also need SAML trace enabled at the SP and the generated SAML log file.
You're welcome to send these to support@componentspace.com mentioning your forum post.

Regards
ComponentSpace Development
neil.redfern@bis-web.com
neil.redfern@bis-web.com
New Member
New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)New Member (5 reputation)

Group: Forum Members
Posts: 3, Visits: 4
ComponentSpace - 7/19/2019
Hi Neil,
I'm not sure why this would be specific to mobile devices.
In both instances (mobile and desktop) do users start at the same SP website and then SSO to ADFS?
If so, I would expect they would use the same SAML configuration.
Are users prompted to login at ADFS in both instances?
To investigate further we would need the associated error events in the Windows ever log on the ADFS server.
We would also need SAML trace enabled at the SP and the generated SAML log file.
You're welcome to send these to support@componentspace.com mentioning your forum post.

Hello,

Thanks for the response, and sorry about the delay in responding.

We have not been able to get the error message, but we have found that changing the redirection method to a HTTP Post resolves the issue.

I suspect that the mobile browser was truncating the URL which was causing issues.

Thanks

Neil
ComponentSpace
ComponentSpace
ComponentSpace Development
ComponentSpace Development (2.9K reputation)ComponentSpace Development (2.9K reputation)ComponentSpace Development (2.9K reputation)ComponentSpace Development (2.9K reputation)ComponentSpace Development (2.9K reputation)ComponentSpace Development (2.9K reputation)ComponentSpace Development (2.9K reputation)ComponentSpace Development (2.9K reputation)ComponentSpace Development (2.9K reputation)

Group: Administrators
Posts: 2K, Visits: 4.6K
Hi Neil,
A truncated URL would definitely do it.
However, we haven't seen this occurring on Android or iOS using Chrome or Safari etc.

Regards
ComponentSpace Development
GO


Similar Topics


Execution: 0.000. 2 queries. Compression Enabled.
Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....









ComponentSpace Forums


Search