ComponentSpace

Forums



JumpCloud could not connect to your application ... Asp.Net Core 3.1 SSO port from .Net v4.x


JumpCloud could not connect to your application ... Asp.Net Core 3.1...

Author
Message
Siddharth Seth
Siddharth Seth
New Member
New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)

Group: Forum Members
Posts: 2, Visits: 28
Hello,
We just ported our ASP.Net MVC application from .Net Framework v4.x to .Net Core v3.1. I am trying to configure SSO and have followed the examples in Component Space documentation. Currently when I try to access the Service Provider application URL ... I get redirected to sso.jumpcloud.com and after I successfully authenticate ... I am expecting to get redirected back to my application URL ... Instead I get redirected to console.jumpcloud.com/userconsole#?error=SAMLerror ... There is a toast message on the page stating "JumpCloud could not connect to your application. If the problem persists....". There is very little other detail to be able to troubleshoot the issue. Any insight or help would be welcome.
ComponentSpace
ComponentSpace
ComponentSpace Development
ComponentSpace Development (3.9K reputation)ComponentSpace Development (3.9K reputation)ComponentSpace Development (3.9K reputation)ComponentSpace Development (3.9K reputation)ComponentSpace Development (3.9K reputation)ComponentSpace Development (3.9K reputation)ComponentSpace Development (3.9K reputation)ComponentSpace Development (3.9K reputation)ComponentSpace Development (3.9K reputation)

Group: Administrators
Posts: 2.8K, Visits: 8.6K
It's most likely a configuration mismatch but it's difficult to debug without more information. I suggest double checking that the configuration in JumpCloud is correct. For example, ensure the assertion consumer service URL is correct.
If there's still an issue, please enable SAML trace in your application and send the generated log file as an email attachment to support@componentspace.com mentioning your forum post.
https://www.componentspace.com/Forums/7936/Enabling-SAML-Trace
Also include screenshots of the configuration information in JumpCloud so we can check it too.

Regards
ComponentSpace Development
Siddharth Seth
Siddharth Seth
New Member
New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)New Member (3 reputation)

Group: Forum Members
Posts: 2, Visits: 28
ComponentSpace - 3/6/2021
It's most likely a configuration mismatch but it's difficult to debug without more information. I suggest double checking that the configuration in JumpCloud is correct. For example, ensure the assertion consumer service URL is correct.
If there's still an issue, please enable SAML trace in your application and send the generated log file as an email attachment to support@componentspace.com mentioning your forum post.
https://www.componentspace.com/Forums/7936/Enabling-SAML-Trace
Also include screenshots of the configuration information in JumpCloud so we can check it too.

I tweaked the configuration after going over it...I do get redirected to my Service Provider application's assertion consumer ... But the below error is thrown and I get a 500 error page ...

"A SAML message cannot be received as the HTTP request is unrecognized. Inner Exception StackTrace: at ComponentSpace.Saml2.SamlProvider.ReceiveMessageAsync() at ComponentSpace.Saml2.SamlServiceProvider.ReceiveSsoAsync() at UplandDataWarehouse.Web.Controllers.Saml.SamlController.AssertionConsumerService()..."

Also, could you point me to a resource to switch on the SAML tracing through appSettings.json file of my project... We are currently using a custom middleware for error reporting in the Service Provider ... It sends out emails with error details...
ComponentSpace
ComponentSpace
ComponentSpace Development
ComponentSpace Development (3.9K reputation)ComponentSpace Development (3.9K reputation)ComponentSpace Development (3.9K reputation)ComponentSpace Development (3.9K reputation)ComponentSpace Development (3.9K reputation)ComponentSpace Development (3.9K reputation)ComponentSpace Development (3.9K reputation)ComponentSpace Development (3.9K reputation)ComponentSpace Development (3.9K reputation)

Group: Administrators
Posts: 2.8K, Visits: 8.6K
The exception indicates the HTTP request isn't recognized as containing a SAML message. The SAML log file would provide more information.

The link I included above (and below) explains how to turn on SAML trace. We use the standard ASP.NET Core logging API.

https://www.componentspace.com/Forums/7936/Enabling-SAML-Trace


Regards
ComponentSpace Development
GO


Similar Topics


Execution: 0.000. 2 queries. Compression Enabled.
Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....









Forums, Documentation & Knowledge Base - ComponentSpace


Search