ComponentSpace

Forums



Google IDP integration


Google IDP integration

Author
Message
[email protected]
greg.zhang@simulationiq.com
New Member
New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)

Group: Forum Members
Posts: 1, Visits: 3
Hi,

One of my client is using google IDP, I did the same thing as others but got this error

The partner identity provider https://accounts.google.com/o/saml2/idp?idpid=C02afg1gr is not configured.

The saml config is like this, did I miss anything? I got error when calling
 SAMLServiceProvider.InitiateSSO(Response, returnUrl, partnerIdP);

partnerIdP= https://accounts.google.com/o/saml2/idp?idpid=C02afg1gr




<PartnerIdentityProvider Name="https://accounts.google.com/o/saml2?idpid=C02afg1gr"
  PartnerCertificateString="xxxx"
  NameIDFormat="urn:oasis:names:tc:SAML:1.1:nameid-format:emailAddress"
  SingleSignOnServiceUrl="https://accounts.google.com/o/saml2/idp?idpid=C02afg1gr"



ComponentSpace
ComponentSpace
ComponentSpace Development
ComponentSpace Development (4.2K reputation)ComponentSpace Development (4.2K reputation)ComponentSpace Development (4.2K reputation)ComponentSpace Development (4.2K reputation)ComponentSpace Development (4.2K reputation)ComponentSpace Development (4.2K reputation)ComponentSpace Development (4.2K reputation)ComponentSpace Development (4.2K reputation)ComponentSpace Development (4.2K reputation)

Group: Administrators
Posts: 3K, Visits: 10K
The partner name parameter to the SAMLServiceProvider.InitiateSSO must exactly match one of the <PartnerIdentityProvider> Name values in your saml.config. We don't match on the SingleSignOnServiceUrl.

It looks like the parameter value is "https://accounts.google.com/o/saml2/idp?idpid=C02afg1gr". However, the configured name is "https://accounts.google.com/o/saml2?idpid=C02afg1gr".

It looks like you specified the SingleSignOnServiceUrl rather than the <PartnerIdentityProvider> Name as the parameter to SAMLServiceProvider.InitiateSSO.

Try specifying "https://accounts.google.com/o/saml2?idpid=C02afg1gr" as the partner name parameter.

Regards
ComponentSpace Development
GO


Similar Topics


Execution: 0.000. 2 queries. Compression Enabled.
Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....












Forums, Documentation & Knowledge Base - ComponentSpace


Search